Wednesday, December 5, 2007

Broken Cups in Your OS X Cupboard

I work a lot with pictures professionally and have been using Apple computers for most of my career, except my Master's Thesis which I wrote on a DEC PDP 11. I was only a user. However, it always struck me with trepidation that I did not understand a thing of what was going on under the hood. I was eventually roped into computing, when the Apple operating system turned to UNIX around the year 2000. With the introduction of OS X, Apple had opened itself to Open Source computing which opened a new universe to me. Seven years later, I spent way more time with compiling packages than I ought to, and way more often than I liked, I ended up in a real fix. Regardless, the euphoria of empowerment outweighed the disappointment by far.

Today I report on one example of the kinds of adventure one may encounter on this road. Several months ago, I happened on the website of cups printing. Cups is the printing routine used in OS X. I found a pre-compiled binary of a more recent version than I had ready for installation. Since I wanted to be at the cutting edge, I downloaded the offering and installed it without reading the fine print. The result was that I could not print anymore. The fine print said that one had to re-install the operating system, if the update did not work. Oh!

I was not prepared to do that. So I compiled the most recent 1.4.x version for developers from source myself and installed it. After that, I could not even get passed the login window. I had a series of sweaty moments since then. I did not believe the functions that depend on cups! Much of OS X appears to depend on the cups library in one way or another. How can this be in the age decentralization? I managed to fix the problem by re-installing n older version in the single user mode.

Months later, I re-visited the cups website. The pre-compiled packages were gone, and it was recommended to try one the versions 1.3.x. After a number of tries, one of them worked and I offer the result on my project (Software for Small Budget Science). The package is compiled with Tiger on Intel. It has worked well for me. However, one nuisance remains. The package needs to be reinstalled after each Apple security update. Let my adventure be a warning.

Apple iTunes

No comments: